Edge functions currently disabled for us-east-1 region
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 18:16 UTC
Monitoring
We believe the network connectivity issues we were seeing in us-east-1 have been resolved, and the region has been re-enabled.

You may now specify it, and it will also participate in requests without a region specified again.

We'll monitor for any additional errors, but things are looking good now.
Posted Sep 26, 2024 - 17:06 UTC
Update
We have temporarily disabled edge functions in us-east-1. Requests without a region should reroute to another region automatically; however, if you specify us-east-1 for any of your functions, please choose another region at this time.

We've added capacity to other regions, and global error rates have returned to normal levels.

We are working with AWS on a resolution and hope to re-enable us-east-1 soon.

We will provide additional updates as we have them.
Posted Sep 26, 2024 - 16:28 UTC
Identified
We have identified network connectivity issues at our hosting provider (AWS) in us-east-1, which is preventing requests from reaching edge functions. We are looking into solutions.

Increased pressure in other regions due to requests being rerouted around us-east-1 are resulting in higher than normal error rates, for which we are currently increasing resources to accommodate the additional traffic.
Posted Sep 26, 2024 - 15:57 UTC
Investigating
We are currently investigating this issue.
Posted Sep 26, 2024 - 15:33 UTC
This incident affected: Edge Functions.