Supabase File Storage - outage for new projects
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 01:11 UTC
Monitoring
A fix has been rolled out for projects that were created during the outage period.
Posted Aug 17, 2022 - 00:28 UTC
Update
This issue has been fixed for new projects and we are working on porting the fix to affected projects.
Posted Aug 16, 2022 - 21:45 UTC
Identified
Update
------------
We've identified the issue and we're working on a fix.

Background
------------
We've released a new extension on the platform which moves the "uuid" type into a new schema. As a result the storage server (which relies on this extension) was unable to create the relevant schema. We're cutting a new version of our Postgres image to fix this, which could take some time.

If you're creating a new project today, please be aware that it could take several hours for us to fix this issue.

All other parts of your Supabase project appear to be unaffected.
Posted Aug 16, 2022 - 19:50 UTC
Investigating
We've received reports that Supabase File Storage is not working for new projects. We are investigating.

At this time it seems like this outage is only affection projects created after 9am PST (16 August). All other projects are unaffected.
Posted Aug 16, 2022 - 17:55 UTC