Some edge function deployment operations are timing out

Incident Report for Supabase

Resolved

ESM has resolved their issue. All function deploy actions should now be working.
Posted Jan 07, 2026 - 19:23 UTC

Monitoring

To address function deploy issues, replace esm.sh with npm: or jsr imports instead. This workaround is confirmed to work.
Posted Jan 07, 2026 - 18:54 UTC

Identified

For users experiencing this issue: esm.sh is having issues. Users can replace esm.sh with npm: or jsr imports to get function deploys to work.
Posted Jan 07, 2026 - 18:40 UTC

Investigating

We are seeing increased timeouts when deploying edge functions and are currently investigating. Already deployed functions are not affected.
Posted Jan 07, 2026 - 18:14 UTC
This incident affected: Edge Functions.