Shared SMTP service has low deliverability

Incident Report for Supabase

Resolved

We worked with our email provider to restore the shared SMTP service, and email delivery has now fully returned to normal.

All emails are being delivered as expected. We’ll be following up internally to implement preventative measures to reduce the likelihood of this happening again.
Posted Dec 22, 2025 - 07:57 UTC

Update

We are continuing to work on a solution for this issue. 



To clarify the impact: This only affects the shared SMTP service, which is intended for testing use only.



The team is, in parallel, continuing to work with our mail provider and is preparing a migration to a different service - we will go with whichever solution happens the earliest; however, this migration must be done carefully to avoid further issues.

If you need email services working immediately, you can still work around this immediately by following best practice for production use cases and configure custom SMTP: https://supabase.com/docs/guides/auth/auth-smtp

We expect to have an update no later than December 22 at 0900 UTC; however, we will share more information if it becomes available earlier.
Posted Dec 21, 2025 - 21:40 UTC

Update

We are continuing to work on a solution for this issue.

You can still work around this immediately by following best practice for production use cases and configure custom SMTP: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 20:35 UTC

Update

We are working with the email provider for shared SMTP services.

For now, users without Custom SMTP will continue to see email deliverability issues for auth-related emails.

We are also exploring other provider options in the event we need to migrate in the near term.

You can still work around this immediately by following best practice for production use cases and configure custom SMTP: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 19:05 UTC

Identified

We have identified the issues with sending mail via the shared SMTP service and are working on a fix.

For any production workloads, we would still strongly encourage setting up custom SMTP on your projects. More information available on configuring that here: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 18:12 UTC

Update

All projects using Supabase shared SMTP are experiencing emails going undelivered.
We are currently investigating, but an immediate workaround is to use custom SMTP.
More information available on configuring that here: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 17:18 UTC

Update

We are continuing to investigate this issue.
Posted Dec 21, 2025 - 17:17 UTC

Update

All projects using Supabase shared SMTP are experiencing emails going undelivered.
We are currently investigating, but an immediate workaround is to use custom SMTP.
More information available on configuring that here: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 17:13 UTC

Investigating

All projects using Supabase shared SMTP are experiencing emails going undelivered.
We are currently investigating, but an immediate workaround is to use custom SMTP.
More information available on configuring that here: https://supabase.com/docs/guides/auth/auth-smtp
Posted Dec 21, 2025 - 17:07 UTC
This incident affected: Auth.