Sign-in failures for `signInWithIdToken` (OIDC) logins on free-tier projects

Incident Report for Supabase

Resolved

We have confirmed that the fix has been effective and are marking this incident as resolved.
Posted Aug 19, 2026 - 15:56 UTC

Update

We've identified that starting 4pm UTC on August 18th we began seeing sign-in failures with signInWithIdToken (OIDC) logins on free-tier projects. Users authenticating with OIDC providers other than Google/Apple/Firebase may have seen failed login attempts.

We've identified the root cause and fix has been rolled out. We are monitoring for continued stability.
Posted Aug 19, 2026 - 13:01 UTC

Update

We've identified that starting 4pm UTC on August 18th we began seeing sign-in failures with signInWithIdToken (OIDC) logins on free-tier projects.  Users authenticating with OIDC providers other than Google/Apple/Firebase may have seen failed login attempts.

We've identified the root cause and fix has been rolled out.
Posted Aug 19, 2026 - 12:48 UTC

Monitoring

We've identified an issue causing sign-in failures for `signInWithIdToken` (OIDC) logins on free-tier projects. Users authenticating with non-Google/Apple/Firebase OIDC providers may see failed login attempts.

We've identified the root cause and fix has been rolled out.

Impacted timeframe was 18th August 4pm UTC - 19th Aug 10:30am UTC
Posted Aug 19, 2026 - 12:47 UTC