supabase-js client lib JSR issue in Edge Functions

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 20:19 UTC

Update

We are continuing to monitor for any further issues with Edge Function deployments
Posted Jun 04, 2025 - 14:22 UTC

Monitoring

A fix has been deployed and we are monitoring Edge Function deploys.
Posted Jun 04, 2025 - 11:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 04, 2025 - 09:58 UTC

Identified

The team has identified an issue with the latest version of supabase-js from JSR in Edge Functions.

A fix has been identified and is being worked on.

In the meantime, you can apply the following mitigations to maintain normal functionality:
* use version 2.49.8 of the library
* use import { createClient } from "npm:@supabase/supabase-js@2"
Posted Jun 04, 2025 - 09:41 UTC
This incident affected: Edge Functions.