Functions management API is returning 500s for multiple function operations

Incident Report for Supabase

Resolved

Edge Function API requests have returned to normal. This issue is now resolved.
Posted Jul 01, 2026 - 16:12 UTC

Monitoring

We have implemented a fix, and error rates have returned to expected levels.
We are continuing to monitor the platform closely to ensure the issue is fully resolved.
Posted Jul 01, 2026 - 15:30 UTC

Identified

The team has identified the root cause of the issue and is currently rolling out a fix across the platform.
We will continue to monitor the rollout and provide another update once it has been completed.
Posted Jul 01, 2026 - 14:59 UTC

Investigating

We are currently investigating an issue affecting the Edge Function API requests.
Our team is working on a fix, and we will provide another update as soon as more information becomes available.
Posted Jul 01, 2026 - 14:40 UTC
This incident affected: Edge Functions.