Things have remained stable, and all systems looking good. This issue has been resolved.
Posted Feb 26, 2026 - 02:23 UTC
Monitoring
Project Pause requests and Replica configuration changes are back to normal. We're monitoring to ensure stability.
Posted Feb 26, 2026 - 01:53 UTC
Update
The job queue is continuing to decrease. The team is making further changes to help it complete faster.
Note: The impact of this remains project pause and read replica configuration change delays. All projects remain up and accessible.
Posted Feb 26, 2026 - 01:28 UTC
Update
The queued jobs are being processed, and pause events and read replica configuration changes will complete as expected once the jobs are processed. The team is, in parallel, looking into making some adjustments to help these processes complete faster.
Posted Feb 26, 2026 - 00:51 UTC
Identified
We've identified a spike in queued jobs in the region, which are resulting in pause and read replica actions delayed. The team is looking into this spike and remediation options.
Posted Feb 26, 2026 - 00:19 UTC
Investigating
We are seeing delays when attempting to pause projects and/or add or remove replicas in EU-West-1. The team is currently looking into this and will update