We have opened a follow-up issue with our provider to address the continued problems a subset of our customers in the Americas are experiencing with top-level ".co" domain resolution. We will continue to pursue this issue until it is resolved and customers who have reported the issue are able to correctly resolve the domain name.
Posted Jun 08, 2026 - 17:32 UTC
Update
Our testing has observed that the issue is related to selected ISP resolvers to .co domains. The clients impacted are mainly located in us-east-1, us-east-2 region. We continue to review this issue for resolution with our third party network partner.
Posted Jun 08, 2026 - 12:38 UTC
Monitoring
The third-party has confirmed a fix has been implemented and we are validating the results with our impacted users.
Posted Jun 08, 2026 - 06:37 UTC
Identified
We are investigating reports of DNS resolution failures affecting a subset of customers connecting to Supabase project endpoints. This appears to be related to a third-party issue with .co TLD resolution impacting multiple DNS providers.
Customers may be able to bypass this issue by using a VPN while we work towards resolution. We will update the statuspage when we have more information to share.