Supabase dashboard experiencing intermittent errors in Europe region

Incident Report for Supabase

Resolved

We have confirmed that project creation has returned to normal.
Posted Mar 27, 2026 - 18:43 UTC

Monitoring

Project creation has returned to normal. We continue to actively monitor and operate our platform for stability and consistency.
Posted Mar 27, 2026 - 18:18 UTC

Identified

We have experienced problems with project creation, the issue has been identified and mitigation steps have been implemented.
Posted Mar 27, 2026 - 17:58 UTC