High error rates for API requests related to user_content in the dashboard

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 21:27 UTC

Monitoring

We determined that there was a spike in activity relating to saved content (queries and folders in the SQL Editor). Things are looking normal at the moment. We are re-enabling saved query and folder access and will monitor for any increased error rates in the management API.
Posted Aug 18, 2025 - 20:59 UTC

Investigating

We've spotted high error rates for some of the API requests. We made a temporary fix that prevents access to saved queries and folders. We are actively working on getting things back to normal and turning this functionality back on.
Posted Aug 18, 2025 - 20:27 UTC
This incident affected: API Gateway and Management API.