pgBouncer issues on some older projects

Incident Report for Supabase

Update

Some users on Project versions 15.1 and older are experiencing a pgBouncer configuration issue causing connection issues for the Dedicated Pooler and Storage services. We are continuing our investigation of this issue.
Posted Aug 26, 2026 - 21:36 UTC

Investigating

Some users on older Projects are experiencing a pgBouncer configuration issue causing connection issues for the Dedicated Pooler and Storage services. This issue should only affect users with Project versions 15.1 and older. We have determined the cause of this issue and we are rolling out a fix.
Posted Aug 26, 2026 - 19:49 UTC
This incident affects: Connection Pooler and Storage.