Rolling JWTs has been temporary disabled

Incident Report for Supabase

Resolved

JWT Re-rolls have been re-enabled.
Posted Jun 18, 2025 - 22:38 UTC

Monitoring

We have determined that the reports we have received are isolated, and this is not a systemic issue. We will be re-enabling JWT rolling shortly.
Posted Jun 18, 2025 - 22:32 UTC

Investigating

Some users have seen issues with authenticated API requests after rolling JWTs. Out of an abundance of caution, we have temporarily disabled the ability to roll project JWTs while we investigate.
Posted Jun 18, 2025 - 22:21 UTC
This incident affected: API Gateway and Auth.