Unhealthy Host in Connection Pooler Load Balancer Affecting Projects in us-east-1

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Mar 08, 2025 - 01:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2025 - 01:15 UTC

Investigating

- we are still seeing elevated connection error rates for some customers
Posted Mar 08, 2025 - 00:01 UTC

Identified

Some users are still seeing intermittent connectivity issues with Supvisor in us-east-1. The team is continuing to work on a fix.
Posted Mar 08, 2025 - 00:00 UTC

Update

- We are still seeing some connection timeouts for a few customers
Posted Mar 07, 2025 - 23:00 UTC

Monitoring

- Our AWS health check failed and rebooted a Supavisor node
- This reboot caused some timeouts for new connections for some customer connection pools
- We have added resources to the cluster to prevent further node reboots
- Timeouts have subsided after ~45 minutes
Posted Mar 07, 2025 - 22:10 UTC

Investigating

We are performing some emergency maintenance on our connection pooler cluster in us-east-1.

New connections may timeout during this period.

Expected maintenance period is roughly 30 minutes.
Posted Mar 07, 2025 - 21:40 UTC
This incident affected: Connection Pooler.