Storage errors in EU-Central-2

Incident Report for Supabase

Resolved

All storage operations have returned to normal.
Posted Mar 07, 2026 - 21:56 UTC

Monitoring

The upstream incident has been resolved and we have not observed any additional errors. We will continue to monitor our storage infrastructure for continued stable operations.
Posted Mar 07, 2026 - 21:16 UTC

Update

We are observing storage error rates returning to normal.
Posted Mar 07, 2026 - 20:44 UTC

Identified

We have identified the cause of the storage issue in EU-Central-2. The upstream provider is working to resolve the issue.
Posted Mar 07, 2026 - 20:22 UTC

Investigating

We have noticed that storage uploads and downloads have become degraded in EU-Central-2. We are investigating.
Posted Mar 07, 2026 - 20:12 UTC
This incident affected: Storage.