Regression prevents ALTER ROLE usage in projects running PostgreSQL 17

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 16:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2025 - 11:23 UTC

Update

We've implemented a fix for the issue, which is now in effect for all newly created projects as of 00:00 UTC. We are currently rolling out the fix to existing projects and will provide another update once the rollout is complete.
Posted Jun 06, 2025 - 11:22 UTC

Identified

We have identified a regression affecting projects running PostgreSQL 17 that prevents ALTER ROLE statements from executing successfully against database roles. This issue may impact workflows that rely on role configuration changes.
Posted Jun 05, 2025 - 19:49 UTC

Investigating

We are currently investigating this issue.
Posted Jun 05, 2025 - 19:48 UTC
This incident affected: Database.