Postgres Version Upgrades are temporarily disabled for Projects using Wrappers
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Aug 13, 2024 - 02:23 UTC
Monitoring
All projects are now allowed to use the Postgres Version Upgrades functionality.
Posted Aug 13, 2024 - 01:42 UTC
Update
Projects not using Wrappers can now use the Postgres upgrade functionality.

Upgrades remain disabled for projects that are using older Wrappers versions (< 0.4.1); a fix will be released for this later today.

If you have the Wrappers extension installed but would like to upgrade before a fix is released, you can:
- drop the extension, if you have it installed but are not using it. This will unblock upgrades.
- drop the extension, execute the upgrade, and thereafter create the extension again. Note that this will drop any FDWs managed by Wrappers.

Existing projects continue to be unaffected and are serving traffic normally. Project creation is not affected.
Posted Aug 12, 2024 - 13:42 UTC
Identified
Project upgrades are temporarily disabled, while we investigate an issue that affects projects that are using an older release of Wrappers, and go through an upgrade.

Existing projects are unaffected and continue to serve traffic normally. Project creation is not affected.
Posted Aug 12, 2024 - 13:09 UTC
Investigating
We are currently investigating this issue.
Posted Aug 12, 2024 - 13:00 UTC