Project operations take longer than usual

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 15:24 UTC

Monitoring

The issue was resolved and we are fully back to normal. We will monitor to make sure the problem doesn’t come back.
Posted Jul 21, 2025 - 14:09 UTC

Update

Our measures solved the majority of issues and most of the queued jobs have now been successfully run. We are still working on the clearing up the last batch of the jobs remaining in the queue.
Posted Jul 21, 2025 - 13:39 UTC

Identified

We have found an issue and implemented a fix. We have also increased capacity for a background worker that runs the queued project operations to speed it up.
Posted Jul 21, 2025 - 12:29 UTC

Investigating

We are seeing longer-than-usual wait times for project creation, restarts, and configuration change events.
Posted Jul 21, 2025 - 11:59 UTC
This incident affected: Management API.