Upgrade Failures

Incident Report for Supabase

Monitoring

We have implemented all necessary mitigations and the project upgrade rates have returned to normal across the fleet. We will continue to monitor these flows for any irregularities or recurring degradation. If you are still experiencing delayed or blocked upgrades on your Project, please contact Support.
Posted Jun 25, 2026 - 18:08 UTC

Update

We are starting to notice improvements as a result of our mitigation efforts, and expect that project upgrades should start to become less delayed. We’ll continue monitoring and will update as we observe improvements across the fleet.
Posted Jun 25, 2026 - 17:46 UTC

Update

We are continuing our operational and investigative work to improve upgrade flow performance and mitigate further problems.
Posted Jun 25, 2026 - 17:03 UTC

Update

We are implementing operational mitigations to try to improve upgrade performance.
Posted Jun 25, 2026 - 16:27 UTC

Update

We are continuing to work through a variety of options for improving upgrade performance. This includes working with our upstream provider and adjusting operational parameters.
Posted Jun 25, 2026 - 16:03 UTC

Update

We are aware that upgrades continue to be delayed. We are exploring other factors that are contributing to the slow upgrades.
Posted Jun 25, 2026 - 15:32 UTC

Identified

The upgrade delays have been caused by resource capacity limits. We are taking actions to increase the appropriate resources.
Posted Jun 25, 2026 - 15:01 UTC

Update

Upgrades are taking longer than usual, but generally will complete if allowed to proceed. We are investigating the cause of the delays.
Posted Jun 25, 2026 - 14:41 UTC

Investigating

We are investigating potential upgrade issues in multiple regions. We are working to confirm impact and determine next steps.
Posted Jun 25, 2026 - 14:20 UTC
This incident affects: Database.