Errors in JWT structure on Supabase auth
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Jul 12, 2024 - 20:43 UTC
Monitoring
The fix has now been rolled out to all regions.

If you are still experiencing issues with user logins, please open a ticket with our support here: https://supabase.help
Posted Jul 12, 2024 - 19:08 UTC
Update
EU-Central-1 has completed. Only AP-* regions still in progress.
Posted Jul 12, 2024 - 18:50 UTC
Update
The fix has rolled out to all US / SA regions, and most EU regions. EU-Central-1 and all AP-* regions are still in progress.
Posted Jul 12, 2024 - 18:13 UTC
Update
Mitigations are still being rolled out across the fleet. We will update again once these are complete.
Posted Jul 12, 2024 - 15:22 UTC
Update
We have also discovered that a small number of projects may see user login failures, for new user signups after ~0900 UTC. We are currently working on remediation steps to get these resolved as well.
Posted Jul 12, 2024 - 13:15 UTC
Update
We have identified an additional issue with new user signups to the Supabase Platform related to this incident.

New accounts created from ~11:45 UTC today may have issues logging into their Supabase account or changing their password.

We are working on a resolution to this, and will reach out to all affected signups directly
Posted Jul 12, 2024 - 12:10 UTC
Update
All affected customers have been rolled back and the release rollout has been paused.
Posted Jul 12, 2024 - 11:27 UTC
Identified
We have identified errors in some Auth projects caused by a new release, engineers are working to roll back the release and fix the issue.
Posted Jul 12, 2024 - 11:11 UTC
Investigating
We are currently investigating this issue.
Posted Jul 12, 2024 - 10:58 UTC
This incident affected: Auth and Dashboard.