The issue affecting Edge Functions has now been fully resolved, and users have reported Edge Functions operating as expected. The root cause was a denial-of-service event that led to elevated error rates and 504 responses across impacted regions. Mitigations have been implemented to restore stability. We will be publishing a full post-mortem with additional details, once our internal review is complete. Thank you for your patience while we worked to resolve this issue.
Posted Feb 28, 2026 - 14:29 UTC
Monitoring
The fix has been implemented and early indicators suggest it has resolved the 504 errors affecting Edge Functions. We are continuing to monitor system performance closely to ensure stability and confirm full recovery across all affected regions. We will provide a final update once we are confident the issue is fully resolved.
Posted Feb 28, 2026 - 14:09 UTC
Identified
We believe we have identified the underlying cause of the 504 errors affecting Edge Functions across multiple regions. The team are currently implementing corrective measures to address the issue and restore service stability.
Posted Feb 28, 2026 - 14:04 UTC
Update
We are continuing to investigate reports of Edge Functions returning 504 errors across multiple regions. Our team is still working to determine the underlying cause. We understand the disruption this may be causing and are treating this with high priority.
Posted Feb 28, 2026 - 13:48 UTC
Investigating
We are currently investigating reports of Edge Functions returning 504 errors across multiple regions.
The team has been alerted and is actively investigating the root cause. We are working to identify the scope of affected regions.
We will provide an update as soon as we have more information.