Degraded API and Dashboard performance in eu-west-1

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 19:44 UTC

Monitoring

We have identified an issue resulting in our management API being slow or unresponsive. We have added additional capacity, and are monitoring for any continued issues.

Please note this does not affect project APIs, but would show as slowness in the dashboard, making changes via the Supabase CLI, or other integration points with the Supabase Management API.
Posted Jun 15, 2025 - 19:16 UTC
This incident affected: Dashboard and Management API.