This incident has been resolved. Administrative operations in the Supabase Dashboard are completing as expected, and we have observed no further permission related errors following the fix.
Posted Sep 24, 2026 - 11:49 UTC
Monitoring
We have applied a fix, and administrative operations in the Supabase Dashboard are now completing as expected. We are monitoring the results to ensure the issue is fully resolved.
Posted Sep 24, 2026 - 11:08 UTC
Identified
We have identified the issue causing some users to encounter permission-related errors, such as “You need additional permissions,” when performing administrative actions in the Supabase Dashboard. We are working on a fix and will provide another update once it has been implemented.
Posted Sep 24, 2026 - 10:50 UTC
Investigating
We are investigating reports of users encountering permission-related errors, such as “You need additional permissions,” when performing administrative actions in the Supabase Dashboard. This may prevent some users from managing their projects through the Dashboard. We are working to identify the cause and will provide further updates as they become available.