Issues propagating Postgres configuration updates

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 07:41 UTC

Monitoring

A fix has been implemented and we are monitoring.
Posted Mar 17, 2026 - 07:07 UTC

Identified

We have identified the root cause and are currently working on a fix.
Posted Mar 17, 2026 - 05:11 UTC

Investigating

Some custom Postgres configurations applied through the Supabase CLI are not currently taking effect for projects running Postgres version 17.6.1.084. Projects that do not use CLI-managed Postgres configurations, or that are running earlier Postgres versions, are not affected.
Posted Mar 17, 2026 - 04:50 UTC