Elevated 525 error rates in the US region

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 13:14 UTC

Monitoring

The error rates are back to normal and all systems are fully operational now. We will continue to monitor to make sure the issue doesn’t arise again.
Posted Aug 28, 2025 - 11:20 UTC

Update

We are observing that error rates are going down. Though they still remain at a higher level than usual.

We are continuing the work with the upstream provider as well as monitor impact on our side.
Posted Aug 28, 2025 - 11:05 UTC

Investigating

We're seeing high 525 error rates for API requests in the US region. We currently believe there may be a problem with our upstream networking partner and are looking to validate.
Posted Aug 28, 2025 - 10:36 UTC
This incident affected: API Gateway and Management API.