Degraded Log Explorer in the dashboard

Incident Report for Supabase

Resolved

We have rolled out additional performance improvements to reporting API endpoints.
Posted Jun 16, 2026 - 15:08 UTC

Monitoring

We are seeing things have stabilized across the fleet after further optimization work, and we are monitoring to ensure no further issues arise.
Posted Jun 16, 2026 - 13:30 UTC

Identified

The mitigations rolled out have resulted in a great reduction in errors and most users should now see fully-functional logging and usage charts; however, some users may still see erroneously empty usage charts on the project home page. The team is continuing to work on this issue.
Posted Jun 16, 2026 - 13:01 UTC

Monitoring

Some users are seeing errors or degraded performance on usage reportss and logs in the Supabase dashboard. The team has already rolled out mitigations and are seeing improvements. We are continuing to monitor the results.
Posted Jun 16, 2026 - 11:26 UTC
This incident affected: Analytics.