DNS creation delays

Incident Report for Supabase

Resolved

The incident has been resolved.
Posted Jul 31, 2026 - 13:26 UTC

Monitoring

The upstream DNS provider has implemented a fix and is monitoring the results. We are seeing signs of recovery; we will continue to monitor the situation and will provide further updates as more information becomes available.
Posted Jul 31, 2026 - 12:55 UTC

Identified

We have identified that the issue is with an upstream DNS provider, causing DNS creation delays for newly created, unpaused, or updated databases. Our team is actively monitoring the situation and will provide further updates as more information becomes available.
Posted Jul 31, 2026 - 12:41 UTC

Investigating

We're investigating issues updating DNS records for newly created, unpaused, or updated databases.
Posted Jul 31, 2026 - 12:27 UTC
This incident affected: API Gateway and Database.