Some users experiencing issue restoring backups

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 01:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 23:10 UTC

Update

The fix is still making its way out to the fleet. We estimate it will be deployed to all affected projects in the next 2-3 hours.
Posted Apr 08, 2025 - 18:18 UTC

Update

We have fixed this issue for any newly created projects, so no additional users are affected. The team is currently rolling out the fix to any remaining projects which would have seen issues attempting to restore.

As a reminder all backups are safe - the issue is in the restore process itself, not the backup process.
Posted Apr 08, 2025 - 15:39 UTC

Identified

Some users attempting to restore backups may see a restore to a more recent point than they selected. All backup data is safe and accounted for, and we are working on a fix for the restore process.
Posted Apr 08, 2025 - 14:08 UTC
This incident affected: Database.