Subscription Plan changes currently unavailable

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 13:58 UTC

Monitoring

A fix has been applied by our upstream provider and we have re-enabled subscription plan upgrades and paid organization creation. We are monitoring to confirm full recovery.
Posted Mar 07, 2026 - 13:23 UTC

Update

We have temporarily disabled subscription plan upgrades and paid organization creation while we work with our upstream billing provider to resolve the issue. We’ll provide an update as soon as we have more information.
Posted Mar 07, 2026 - 12:45 UTC

Investigating

We are currently experiencing issues with subscription plan changes and have contacted our upstream billing provider to help investigate. Subscription Plan changes are temporarily disabled while we investigate.
Posted Mar 07, 2026 - 12:10 UTC