Read Replica creation is temporarily disabled
Incident Report for Supabase
Resolved
The fix has now been rolled out to all impacted read replicas.
Posted Aug 15, 2024 - 12:57 UTC
Monitoring
We have implemented a fix and replica creation has now been re-enabled.
We are in process of rolling out the fix to the impacted read replicas.
Posted Aug 15, 2024 - 11:51 UTC
Identified
A fix is currently being implemented.
We recommend not destroying any existing read replicas as creation of new ones is currently disabled.
Posted Aug 15, 2024 - 09:50 UTC
Update
Read replicas created after 2024-08-03 have had their Postgrest service (HTTP Data APIs) set up incorrectly; a fix will be backported to the affected instances.

Other services, including the Postgres database, are not affected.

We recommend not destroying any existing read replicas as creation of new ones remains disabled.
Posted Aug 15, 2024 - 07:17 UTC
Update
We've temporarily disabled replica creation while we investigate an issue with Data APIs (Postgrest) on replicas
Posted Aug 15, 2024 - 05:34 UTC
Investigating
We are currently investigating this issue.
Posted Aug 15, 2024 - 05:32 UTC