Project Lifecycle Actions Showing increased error rates across all regions

Incident Report for Supabase

Update

We are seeing incremental improvements internally. There is a large backlog of actions that we are working through, but things are progressing. Once we make it through most of the backlog, we will re-enable lifecycle actions.

This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc.

Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.
Posted Sep 04, 2026 - 02:02 UTC

Update

The team is continuing to work on restoring project lifecycle operations. Out of caution, we have disabled lifecycle operations.

This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc.

Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.

We will provide additional updates as we have more information.
Posted Sep 04, 2026 - 01:37 UTC

Update

The team has applied a fix, but error rates remain high. We are continuing to work and will take other necessary steps to resolve this as soon as possible.

Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.

Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved: Creates, Configuration changes, Restarts, or Compute size changes. We will provide additional updates as we have more information.
Posted Sep 04, 2026 - 00:58 UTC

Identified

We have identified the source of the errors with project lifecycle actions, and the team is currently working to resolve it.

This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc.

Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.

Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved. We will provide additional updates as we have more information.
Posted Sep 04, 2026 - 00:30 UTC

Investigating

We are seeing increased error rates in actions across all project lifecycle actions - Creations, Deletions, Restores, Configuration and Compute size upgrades. We are currently looking into the cause.

Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved. We will provide additional updates as we have more information
Posted Sep 04, 2026 - 00:15 UTC
This incident affects: Management API.