Some Projects Unreachable following Project Restart

Incident Report for Supabase

Monitoring

All impacted projects with open support tickets have now been manually patched and restored.
We are currently rolling out a fix across the fleet to prevent further impact.
We will continue to monitor progress and provide updates.
Posted Apr 27, 2026 - 13:12 UTC

Update

Our team is actively working on a fix and is manually patching impacted projects to restore service as quickly as possible.

If you are running a version of Postgres older than 15.1.1.57, please avoid restarting your project until this issue is resolved.
Posted Apr 27, 2026 - 11:40 UTC

Update

We’ve identified that a recent change to the Postgres systemd service has a dependency on a prestart script.
This script is not present on some older projects, and when those projects restart, Postgres may fail to start successfully.
This can result in projects remaining offline.
We are working on a fix to restore service.

If you are running a version of Postgres older than 15.1.1.57, please avoid restarting your project until this issue is resolved.
Posted Apr 27, 2026 - 11:11 UTC

Identified

We’ve identified that a recent change to the Postgres systemd service has a dependency on a prestart script.
This script is not present on some older projects, and when those projects restart, Postgres may fail to start successfully.
This can result in projects remaining offline. We are working on a fix to restore service.
Posted Apr 27, 2026 - 10:54 UTC
This incident affects: Dashboard.