Endpoints in Americas regions returning 500 Internal server error

Incident Report for Supabase

Resolved

Operations have returned to normal. We are implementing improvements to prevent similar recurrences in the future.
Posted Jul 06, 2026 - 16:10 UTC

Monitoring

The fix has been applied and there are improvements to the error rates. We are continuing to work on ensuring the underlying issue does not recur.
Posted Jul 06, 2026 - 15:42 UTC

Identified

We have identified the cause of the 500 errors and are implementing a fix.
Posted Jul 06, 2026 - 15:15 UTC

Update

The scope of the errors is across regions in the Americas. We are narrowing down the likely causal chains.
Posted Jul 06, 2026 - 15:10 UTC

Update

The 500 errors are limited to us-east-1, we are actively exploring causes.
Posted Jul 06, 2026 - 14:47 UTC

Investigating

Multiple endpoints are returning 500 Internal server errors across our platform. We are investigating what has caused these errors.
Posted Jul 06, 2026 - 14:45 UTC
This incident affected: Management API.