Delays in creation of DNS records

Incident Report for Supabase

Update

We have identified and mitigated the issue that was blocking DNS updates. DNS record creation is succeeding, and latency has returned to normal levels. A subset of projects that encountered provisioning failures during the incident will require DNS records to be backfilled, and we are actively remediating these affected projects.
Posted Jul 27, 2026 - 20:53 UTC

Identified

We have identified the cause of delays in DNS records creation and are actively working on a fix. We will continue to provide updates as things progress.
Posted Jul 27, 2026 - 20:39 UTC

Investigating

We are investigating failures in provisioning DNS records for projects, there may be delays in creation of DNS records for new or unpaused projects.
Posted Jul 27, 2026 - 20:34 UTC
This incident affects: API Gateway and Database.