Elevated JWT authorization errors

Incident Report for Supabase

Resolved

Edge function operations are normal.
Posted Jul 08, 2026 - 19:57 UTC

Monitoring

A rollback mitigation implemented by our team has addressed the problem. Edge functions have returned to normal. We will continue to monitor performance.
Posted Jul 08, 2026 - 19:28 UTC

Identified

We have identified likely reasons for the problem and are investigating options for resolution. We advise all customers to ensure they are using valid JWT keys with their projects.
Posted Jul 08, 2026 - 19:16 UTC

Investigating

We are aware of reports of elevated legacy JWT authorization errors on edge functions in some regions
Posted Jul 08, 2026 - 18:37 UTC
This incident affected: Edge Functions.