Intermittent Connection Pooler instability in us-west-1

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 18:18 UTC

Monitoring

We have identified the node that was causing connection issues in us-west-1, replaced it, and restarted failing connection pools.

Error rate returned back to normal, but we are still monitoring to ensure the problem doesn’t come back.
Posted Jun 23, 2025 - 16:59 UTC

Investigating

We are investigating connection issues in us-west-1.
Posted Jun 23, 2025 - 16:16 UTC
This incident affected: Connection Pooler.