Degraded Supavisor performance in US-West-1 (Northern California)

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 17:33 UTC

Monitoring

The fix was deployed and the latency stabilized. We are now monitoring to make sure that the issue was fully resolved.
Posted Dec 01, 2025 - 16:35 UTC

Identified

We have identified the problematic Supavisor node and we are working on the fix.
Posted Dec 01, 2025 - 16:21 UTC

Update

We are currently investigating reports of increased Supavisor connection and query execution times in us-west-1 (Northern California)
We'll provide further updates as soon as we have additional information
Posted Dec 01, 2025 - 15:57 UTC

Investigating

We are currently investigating reports of increased Supavisor connection times in us-west-1 (Northern California)
We'll provide further updates as soon as we have additional information
Posted Dec 01, 2025 - 15:50 UTC
This incident affected: Connection Pooler.