Degraded Supavisor performance in us-east-1

Incident Report for Supabase

Resolved

Performance has returned to normal levels. This incident has been resolved.
Posted Feb 17, 2026 - 00:29 UTC

Monitoring

We've identified degraded performance in a Supavisor cluster resulted in elevated connection latency and increased p99 response times. The problematic node has been replaced and performance is returning to normal levels. We will continue to monitor.
Posted Feb 17, 2026 - 00:16 UTC

Investigating

Starting from Feb 22:55 UTC, degraded performance in one of our Supavisor clusters resulted in elevated connection latency and increased query p99 response times.
Posted Feb 16, 2026 - 23:48 UTC