Degraded Management API performance affecting payments and Supabase Studio

Incident Report for Supabase

Resolved

All regions continue to report healthy Management API performance and platform stability.
Posted Jun 17, 2026 - 14:10 UTC

Monitoring

We have resolved the degraded performance affecting our Management API in the impacted regions. All systems are now fully operational.

All payment features have been re-enabled. Customers should no longer experience failed payments or failed project creations.

We are continuing to monitor the system closely and will provide a final update once we have confirmed full stability.
Posted Jun 17, 2026 - 13:15 UTC

Update

We are currently experiencing degraded performance with our Management API in the following regions: ca-central-1, sa-east-1, us-east-1, and us-east-2.

Customers may experience failed payments, failed project creations, and degraded performance in Supabase Studio.

As a precautionary measure, we have temporarily disabled the following features while we investigate:
- Top up Credits
- Update Billing Information
- Redeem Credits

To reduce impact, we have redirected traffic to healthy regions. Our team continues to actively investigate and work toward a full resolution.
Posted Jun 17, 2026 - 12:51 UTC

Investigating

We are currently investigating the issue
Posted Jun 17, 2026 - 12:31 UTC
This incident affected: Compute capacity (ca-central-1, sa-east-1, us-east-1, us-east-2) and Management API.