Elevated Error rates for Edge Functions globally in all regions.

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 23:50 UTC

Monitoring

We increased available resources in us-east-1, which has reduced error rates to normal levels. All regions currently looking stable. Due to the volatility here, we'll be keeping an eye on things for a while to be sure.
Posted Mar 24, 2025 - 22:44 UTC

Identified

US-East-1 has begun showing elevated error rates again. The team is currently looking into these errors now.
Posted Mar 24, 2025 - 22:19 UTC

Monitoring

The fix for the secondary issues has been deployed, and things are looking stable again. We will continue to monitor for any further issues.
Posted Mar 24, 2025 - 22:16 UTC

Update

The fix is still being deployed across the fleet. We hope to have edge functions behaving normally again soon.
Posted Mar 24, 2025 - 21:49 UTC

Identified

We have identified a second issue, and the team is rolling out a fix shortly.

If you are seeing 503s and "worker boot error" messages in your edge function logs, this fix will address those situations.
Posted Mar 24, 2025 - 21:20 UTC

Investigating

Unfortunately, while it immediately appeared that the fix we deployed was working, error rates across all regions have begun to climb again. The team is continuing to investigate.
Posted Mar 24, 2025 - 20:59 UTC

Monitoring

The fix has been deployed. Error rates across all regions have returned to normal levels. We'll keep an eye on things to ensure they remain stable.
Posted Mar 24, 2025 - 20:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 24, 2025 - 19:51 UTC

Update

Elevated error rates have expanded to all regions, globally.
Posted Mar 24, 2025 - 19:36 UTC

Investigating

Users with functions firing in eu-central-1 and eu-west-1, and us-east-1 may see increased error rates. You can, if you like, choose a region to execute functions in to avoid these regions by passing a header. More info on that here: https://supabase.com/docs/guides/functions/regional-invocation
Posted Mar 24, 2025 - 19:34 UTC
This incident affected: Edge Functions.