Network restrictions preventing read replica communication

Incident Report for Supabase

Update

Our team continues to work on implementing a fix for the issue. We are continuing to monitor the impact and will provide additional updates as progress is made.
Posted May 20, 2026 - 23:41 UTC

Identified

We have identified the cause of the issue impacting read replica communication for projects. Our team is actively working on a fix and continuing to assess the impact to affected projects.
Posted May 20, 2026 - 22:48 UTC

Update

We are reviewing the impact of this issue, which is limited to projects with read replicas and network restrictions. We continue to both investigate mitigation options for the issue and identify projects that may be impacted.
Posted May 20, 2026 - 21:46 UTC

Investigating

Network restrictions are preventing read replicas from communicating with their primaries for a limited number of customer projects. We are actively investigating this issue.
Posted May 20, 2026 - 21:04 UTC
This incident affects: Database.