All known affected projects have been fixed at this point, and we are not seeing new errors related to this pg_net issue at this time. We will continue to monitor for any changes.
If you are continuing to see permissions errors related to pg_net tables or objects, please open a ticket at https://supabase.help
Posted Feb 26, 2025 - 16:54 UTC
Update
Nearly all affected projects have been fixed. There are a very small number for which the team is still doing some additional mitigation, but all projects should be back to normal again soon.
Posted Feb 26, 2025 - 15:54 UTC
Update
The fix has been validated, and is currently being deployed to all affected projects.
Posted Feb 26, 2025 - 14:19 UTC
Identified
We've identified the issue as an corner-case of a recent security fix, which impacts projects using pg_net 0.8.0, and causes pg_net requests to fail when executed by a non-superuser. A fix is being worked on and validated, and will be rolled out to impacted projects.
Posted Feb 26, 2025 - 13:18 UTC
Investigating
We are seeing increased reports of permissions issues when using pg_net and the engineering team are investigating.