Branch creation degradation

Incident Report for Supabase

Resolved

Branch creation continues to be stable.
Posted May 21, 2026 - 19:26 UTC

Monitoring

Branch creation has returned to normal. We are investigating a set of factors that likely contributed to the degradation, including cluster load, lock contention, and service start-up sequencing to identify areas for improvement going forward. We will monitor our platform for another 30 minutes to ensure the problem has fully resolved before resolving the incident.
Posted May 21, 2026 - 18:54 UTC

Update

We continue investigating different possible underlying causes and will provide updates as progress is made.
Posted May 21, 2026 - 17:45 UTC

Investigating

We are seeing degradation in branch creation linked to database migration locks. We are investigating and will share further updates as progress is made.
Posted May 21, 2026 - 16:46 UTC