Supabase Connectivity from the Etisalat and Du network in the UAE

Incident Report for Supabase

Postmortem

Between September 2nd and September 20th, 2025, customers in the UAE experienced service outages when attempting to access Supabase projects. The issue was caused by DNS-level blocking implemented by major UAE telecommunications providers Etisalat and Du, citing copyright infringement concerns related to unauthorized usage of our platform.

Customers with projects accessed from within the UAE were completely unable to reach any *.supabase.co domains. The blocking affected all Supabase services including PostgREST, Auth, Storage, Realtime, and Edge Functions.

We sincerely apologize for the extended disruption this caused to your applications and services. Here is additional detail about what happened and the steps we're taking to prevent similar incidents.

What happened?

UAE telecommunications providers Etisalat and Du implemented DNS-level blocking of all *.supabase.co domains after identifying a project that violated broadcasting rights in the region. The providers did not send advance notice or DMCA takedown requests, instead implementing immediate network-wide blocking for all Supabase domains.

The incident timeline was as follows:

  • MON 2 SEP 18:00 UTC: Initial customer reports of connectivity issues from UAE
  • MON 2 SEP 23:30 UTC: Identified DNS blocking by Etisalat, began outreach attempts
  • TUE 3 to FRI 13 SEP: Sent multiple formal and informal communications to ISP NOC contacts
  • WED 10 SEP: Deployed proxy workaround with limited functionality as last resort measure
  • SUN 15 SEP: Our partners were able to reach out directly to Etisalat and worked with them to facilitate unblock
  • SUN 15 SEP: Engaged UAE law firm to handle official TDRA communication
  • MON 16 SEP: Our customer facilitated introduction to TDRA
  • TUE 17 SEP: Etisalat connectivity restored following TDRA intervention
  • WED 18 SEP: TDRA provided details of copyright violations, offending project suspended
  • THU 19 SEP: Du confirmed working on removal of restrictions
  • FRI 20 SEP: Full connectivity restored across all UAE ISPs

What will we do to mitigate problems like this in the future?

  • We have established forward looking proactive strategy with government authorities in the UAE.
  • We are working on a strategy for further proactive regulator engagement.
  • Make abuse reporting channels more visible on our website.

What actions do you need to take?

If you previously switched to a proxy as a workaround, please migrate back to your original *.supabase.co domain as the proxy solution has limited functionality and is not intended for long-term use.

If you experience any lingering connectivity issues from UAE networks, please contact our support team with your project details and ISP information.

Posted Sep 26, 2025 - 15:14 UTC

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 15:11 UTC

Monitoring

Both Etisalat and Du connectivity have been restored. Multiple customers confirm access to `*.supabase.co` domains is working normally across both ISPs. We are monitoring the situation to ensure stability. Thank you for your patience during this incident.
Posted Sep 20, 2025 - 14:39 UTC

Update

We have made significant progress with Etisalat after establishing contact with both Etisalat and TDRA (UAE Telecommunications Regulatory Authority). Multiple customers confirm Etisalat connectivity is restored.

TDRA provided details about the block and has removed restrictions for `*.supabase.co` domains. We are taking the required actions per their guidance.

We are still working to confirm Du has implemented the same changes. If you’re on Du and experiencing issues, please contact support directly.
Posted Sep 18, 2025 - 14:29 UTC

Update

We are still awaiting formal responses from Etisalat and Du despite multiple escalation attempts. We are now pursuing alternative channels of engagement with them. If your customers are primarily located in the UAE, please contact support directly. VPN/proxy connections continue working.
Posted Sep 13, 2025 - 19:11 UTC

Update

We have also received reports of network connectivity issues for users on the Du network in the UAE. We have contacted both Etisalat and Du and are looking forward to working with them both to resolve this as soon as possible. In the interim, connections via VPN, proxy, or from other networks appear to be unaffected.
Posted Sep 06, 2025 - 13:27 UTC

Update

We are still waiting for a response from the Etisalat ISP to resolve the connectivity issues in the UAE. We have reached out to them via multiple channels and are trying to restore connectivity as soon as possible. In the interim, connections via VPN, proxy, or from other networks appear to be unaffected.
Posted Sep 04, 2025 - 08:53 UTC

Identified

We have received reports that users on the Etisalat network in the UAE are unable to connect to Supabase. We have reached out to Etisalat and will work with them to restore connectivity as soon as possible. In the interim, connections via VPN or from other networks appear to be unaffected.
Posted Sep 02, 2025 - 15:57 UTC