MCP connection error to branch environments

Incident Report for Supabase

Resolved

Customers should now be able to connect to branch environments via MCP normally.
Posted Aug 11, 2026 - 18:30 UTC

Update

We have pushed a fix to address the root cause and are monitoring the situation. If you continue to see an error, you can re-authenticate with the Supabase MCP server and also confirm that you have access to the preview branch.
Posted Aug 11, 2026 - 17:48 UTC

Monitoring

UPDATE: We are currently pushing a fix to address the root cause. We'll provide another update once the fix has been fully deployed.
Posted Aug 11, 2026 - 16:33 UTC

Update

We're still working on implementing a fix for the identified root cause.
Posted Aug 11, 2026 - 15:52 UTC

Identified

We've identified the root cause that was leading to permission errors on MCP connections to branch environments. We're currently working on addressing this.
Posted Aug 11, 2026 - 15:09 UTC

Investigating

We're currently investigating an issue that is impacting MCP connections to branch environments.
Posted Aug 11, 2026 - 14:37 UTC