Supabase Dashboard currently returning "An Unexpected Error Occurred"

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 16:03 UTC

Monitoring

We had seen a short regression, but this has also been resolved. We'll keep an eye on this for a while longer to ensure things do not regress again.
Posted Sep 15, 2025 - 15:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 15, 2025 - 14:16 UTC

Monitoring

We have rolled back the faulty change, and the dashboard is loading again. It may require a hard refresh (Shift + refresh). If you are still experiencing issues, please clear cache and try again.
Posted Sep 15, 2025 - 13:52 UTC

Identified

We have identified the change that resulted in the errors and are working to roll that back now.
Posted Sep 15, 2025 - 13:50 UTC

Investigating

We are currently investigating this issue.
Posted Sep 15, 2025 - 13:47 UTC
This incident affected: Dashboard.