Errors across logs and observability services

Incident Report for Supabase

Monitoring

The configuration update has brought error rates and stability back to normal, all logging and observability data should now be accessible.

The impact of this event was limited to log visibility and log retention. Some logs between 20:20 UTC and 23:23 UTC on Friday, Feb 20, 2026 may not be available.

We will continue to monitor to ensure things continue to look good.
Posted Feb 20, 2026 - 23:30 UTC

Update

The team is currently pushing a configuration change we hope will finish stabilizing the analytics services. We will continue to update as we have more information.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.
Posted Feb 20, 2026 - 23:16 UTC

Update

The analytics service continues to be periodically degraded, which means some users may still periodically see issues seeing logging and observability information. We have added additional resources to the logging service to increase stability.

The team is continuing their work to stabilize all analytics functionality.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.
Posted Feb 20, 2026 - 22:23 UTC

Update

We are still seeing logging and observability services continue to stabilize, but some users may continue to see some issues. The team is continuing to working on full stabilization efforts.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.
Posted Feb 20, 2026 - 22:02 UTC

Update

We are still seeing logging and observability services continue to stabilize, but some users may continue to see some issues. The team is continuing to working on full stabilization efforts.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.
Posted Feb 20, 2026 - 21:42 UTC

Update

We've implemented a fix, and we are seeing the affected services begin to stabilize, but access to logs, observability metrics, and edge function invocation information may still be spotty.

The team is continuing to working on full stabilization efforts.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.
Posted Feb 20, 2026 - 21:24 UTC

Identified

We have identified an issue resulting in missing log, observability, and edge function information.

Projects and services are up and running, edge function invocations are unaffected, and project creation/adjustments are unaffected. This only affects visibility of the above mentioned information.

We will have another update within 20 minutes.
Posted Feb 20, 2026 - 21:02 UTC

Update

We are investigating errors across our logs and observability services and will provide an update soon.
Posted Feb 20, 2026 - 20:41 UTC

Investigating

We are investigating errors with Edge Functions and will provide an update soon.
Posted Feb 20, 2026 - 20:37 UTC
This incident affects: Analytics, Dashboard, and Management API.