High connection latency via shared Pooler in us-west-1

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 19:34 UTC

Update

The team noticed that some connection pools had workers stuck as a consequence of the previous issue. This could cause query failures. Stuck workers were now restarted.
Posted Feb 09, 2026 - 18:37 UTC

Monitoring

We've removed the problematic cluster node and latency returned to the normal level. We are now monitoring.
Posted Feb 09, 2026 - 17:56 UTC

Investigating

We’re investigating high latency in us-west-1 affecting some connections to databases via our shared connection pooler.
Posted Feb 09, 2026 - 17:39 UTC
This incident affected: Connection Pooler.