Storage instability in US-East-1

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 19:39 UTC

Monitoring

We've deployed the fix, and currently monitoring to make sure that the issue doesn’t return.
Posted Jul 03, 2025 - 16:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 03, 2025 - 15:17 UTC

Investigating

We are seeing periodic issues with requests to storage in the us-east-1 region.
Posted Jul 03, 2025 - 15:15 UTC
This incident affected: Storage.