Customers will continue to see these delayed transactional emails while we clear the backlog. We will provide another update once these queued emails are sent.
Posted Apr 16, 2026 - 20:51 UTC
Update
We have made progress investigating the specific causes of the email spike and are determining appropriate next steps to improve clearance of the backlog.
Posted Apr 16, 2026 - 19:37 UTC
Monitoring
We are experiencing delays in delivery of some of our email to customers related to transactions, including new welcome, oath-apprroved, project-shutown, and payment-failure notifications. This has caused some customers to receive notifications after their issue has been resolved (for example, payment failure notifications after payment has been issued). We are actively monitoring the email delivery queue and expect the delays to be eliminated over time. We will update this status as appropriate.